No degraded performance reported, all systems are full steam!
Posted Nov 05, 2024 - 23:15 UTC
Monitoring
Our network provider has resolved the issue and our services are back online. We are monitoring.
Posted Nov 05, 2024 - 23:10 UTC
Update
Unfortunately as a result of the critical outage, the game has been privated as all services have ceased to function until further notice. We are sorry about this and hope to get back to operational status soon!
Posted Nov 05, 2024 - 13:07 UTC
Identified
Our network provider has had damage to their infrastructure. Service will be restored soon.